要点
- CVE-2026-42280 は auth0.js (auth0), auth0-js に影響する深刻度「高」 (CVSS 7.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.21%(全脆弱性の 11.4% より高い)。
- 対処:10.0.0 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| auth0.js | ≥ 8.11.0, < 10.0.0
| 10.0.0
|
| auth0-js npm | ≥ 8.11.0, < 10.0.0
| 10.0.0
|
概要
Description
Under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided.
Am I Affected?
Users are affected if they meet each of the following preconditions:
- Applications built using Auth0.js version between 8.11.0 and 9.32.0
- The application’s access control relies on rules defined in Auth0 Actions.
Affected product and versions
auth0.js SDK v8.11.0 to v9.32.0
Resolution
Upgrade auth0/auth0.js to v10.0.0 or greater.
Acknowledgements
Okta would like to thank Quan Le (@aleister1102) for their discovery and responsible disclosure.
NVD の説明
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン