要点
- CVE-2026-48068 は @grpc/grpc-js に影響する深刻度「高」 (CVSS 7.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.88%(全脆弱性の 59.2% より高い)。
- 対処:1.10.12, 1.11.4, 1.12.7, 1.13.5 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| @grpc/grpc-js npm | ≥ 1.10.0, < 1.10.12≥ 1.11.0, < 1.11.4≥ 1.12.0, < 1.12.7≥ 1.13.0, < 1.13.5≥ 1.14.0, < 1.14.4< 1.9.16
| 1.10.121.11.41.12.71.13.51.14.41.9.16
|
概要
Impact
An invalid incoming HTTP/2 stream initiation can cause a server process to crash. This affects all servers created using @grpc/grpc-js.
Patches
The following version have fixes for this vulnerability:
- 1.9.16
- 1.10.12
- 1.11.4
- 1.12.7
- 1.13.5
- 1.14.4
Workarounds
There is no workaround.
NVD の説明
@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン