要点
- CVE-2026-48109 は MessagePack, messagepack (messagepack) に影響する深刻度「高」 (CVSS 8.2) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.51%(全脆弱性の 43.4% より高い)。
- 対処:3.1.7, 2.5.301 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| MessagePack NuGet | ≥ 3.0.214-rc.1, < 3.1.7< 2.5.301
| 3.1.72.5.301
|
| messagepack | ≥ 3.0.3, < 3.1.7< 2.5.301
| 3.1.72.5.301
|
概要
Impact
A vulnerability exists in the optional LZ4 decompression path used by MessagePack compression modes Lz4Block and Lz4BlockArray.
The decoder implementation is based on a deprecated fast-decompression algorithm that does not take a source-length bound. A remote attacker can send a crafted MessagePack payload with manipulated LZ4 token/length fields to force out-of-bounds reads from the compressed input buffer. In affected environments, this can trigger an AccessViolationException during decompression, causing process termination (denial of service). Under some conditions, limited unintended memory disclosure from over-read data may also be possible before failure.
This issue affects applications that deserialize untrusted data while LZ4 compression is enabled.
Patches
The v2 versions are patched as of 2.5.301.
The v3 versions are patched as of 3.1.7.
Workarounds
Instead of upgrading, an application may take the following precautions:
- Disable LZ4 compression for untrusted input paths (
Lz4Block, Lz4BlockArray).
- Only accept compressed payloads from strongly trusted producers.
- Isolate deserialization in a separate process/container with restart supervision to limit availability impact.
Resources
NVD の説明
MessagePack for C# is a MessagePack serializer for C#. Prior to 2.5.301 and 3.1.7, A vulnerability exists in the optional LZ4 decompression path used by MessagePack compression modes Lz4Block and Lz4BlockArray. The decoder implementation is based on a deprecated fast-decompression algorithm that does not take a source-length bound. A remote attacker can send a crafted MessagePack payload with manipulated LZ4 token/length fields to force out-of-bounds reads from the compressed input buffer. In affected environments, this can trigger an AccessViolationException during decompression, causing process termination (denial of service). Under some conditions, limited unintended memory disclosure from over-read data may also be possible before failure. This vulnerability is fixed in 2.5.301 and 3.1.7.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン