要点
- CVE-2026-56383 は craftcms/cms に影響する深刻度「中」 (CVSS 4.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.22%(全脆弱性の 12.3% より高い)。
- 対処:4.16.19, 5.8.23 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| craftcms/cms Packagist | ≥ 4.5.0-beta.1, < 4.16.19≥ 5.0.0-RC1, < 5.8.23
| 4.16.195.8.23
|
概要
A stored Cross-site Scripting (XSS) vulnerability exists in the editableTable.twig component when using the Row Heading column type. The application fails to sanitize input within row headings, allowing an attacker to execute arbitrary JavaScript when another user views a page with the malicious table field.
Prerequisites
Steps to Reproduce
- Navigate to Settings → Fields and create a new field with Type: Table
- Add a Column Heading and set Column Type to
Row Heading
- In Default Values section, add a row with the following payload:
<img src=x onerror="alert('XSS')">
- Enable
Static Rows
- Use the field in any object (e.g., user profile fields) → then visit any user’s profile
- Notice the XSS execution
Resources
https://github.com/craftcms/cms/commit/7b372de262b8d9d2ce859f32780c3715719b6f5a
NVD の説明
Craft CMS contains a stored cross-site scripting (XSS) vulnerability in the editableTable.twig component when using the 'Row Heading' column type. The application fails to sanitize input within row heading default values, allowing an attacker with an administrator account (with allowAdminChanges enabled) to inject arbitrary JavaScript that executes when another user views a page containing the affected table field. Affected versions are >= 4.5.0-beta.1 through 4.16.18 and >= 5.0.0-RC1 through 5.8.22; fixed in 4.16.19 and 5.8.23.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン