| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| activemq | ≥ 6.0.0, < 6.2.8< 5.19.9 | 6.2.85.19.9 |
| activemq all | ≥ 6.0.0, < 6.2.8< 5.19.9 | 6.2.85.19.9 |
| activemq broker | ≥ 6.0.0, < 6.2.8< 5.19.9 | 6.2.85.19.9 |
Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated low-privilege user can bypass a per-destination write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary. This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン