要点
- CVE-2026-64642 は next.js (vercel), next に影響する深刻度「高」 (CVSS 8.2) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.64%(全脆弱性の 50.4% より高い)。
- 対処:16.2.11 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| next.js | ≥ 16.0.0, < 16.2.11
| 16.2.11
|
| next npm | ≥ 16.0.0, < 16.2.11
| 16.2.11
|
概要
Impact
Crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication.
Workarounds
If you cannot upgrade immediately, enforce authorization in the page's server-side data path instead of relying solely on middleware.
NVD の説明
Next.js is a React framework for building full-stack web applications. In versions 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication. This issue has been fixed in version 16.2.11.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン