| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| postgresql | ≥ 15.0, < 15.18≥ 16.0, < 16.14≥ 17.0, < 17.10≥ 18.0, < 18.4< 14.23 | 15.1816.1417.1018.414.23 |
Stack buffer overflow in PostgreSQL module "refint" allows an unprivileged database user to execute arbitrary code as the operating system user running the database. A distinct attack is possible if the application declares a user-controlled column as a "refint" cascade primary key and facilitates user-controlled updates to that column. In that case, a SQL injection allows a primary key update value provider to execute arbitrary SQL as the database user performing the primary key update. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン