| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| tomcat | ≥ 10.1.0, < 10.1.58≥ 11.0.0, < 11.0.25≥ 7.0.97, ≤ 7.0.109≥ 8.5.46, < 9.0.121 | 10.1.5811.0.259.0.121 |
Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン