| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| n8n | = 2.32.0≥ 2.31.0, < 2.31.5 | 2.31.5 |
| n8n | ≥ 2.32.0, < 2.32.1< 2.31.5 | 2.32.12.31.5 |
An authenticated user with permission to create or modify workflows could abuse crafted expressions using arrow functions to bypass the expression sandbox, triggering unintended system command execution on the host running n8n.
The issue has been fixed in n8n versions 2.31.5 and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability.
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン