| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| github.com/hashicorp/boundary | ≥ 0.20.0, < 0.20.3≥ 0.21.0, < 0.21.3< 0.19.5 | 0.20.30.21.30.19.5 |
Boundary Community Edition and Boundary Enterprise ("Boundary") workers are vulnerable to a denial-of-service condition during node enrollment TLS handshakes. An attacker with network access to the worker authentication listener may open a connection and delay or withhold the client certificate during the TLS handshake, causing worker connection handling to block. This may prevent legitimate worker connections from being accepted or routed. This vulnerability, CVE-2026-7776, is fixed in Boundary 0.21.3, 0.20.3, 0.19.5.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン