| Package | Affected versions | Patched versions |
|---|---|---|
| smarty/smarty | ≥ 4.0.0, < 4.0.3< 3.1.43 | 4.0.33.1.43 |
| smarty | ≥ 4.0.0, < 4.0.3< 3.1.43 | 4.0.33.1.43 |
Template authors could run restricted static php methods.
Please upgrade to 3.1.40 or higher.
See the documentation on Smarty security features on the static_classes access filter.
If you have any questions or comments about this advisory please open an issue in the Smarty repo
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free