요약
- CVE-2021-29454은(는) smarty/smarty, smarty (smarty)에 영향을 주는 높음 (CVSS 8.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 1.8%, 전체 취약점의 78.5%보다 높음.
- 조치: 4.0.2, 3.1.42 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.0.2< 3.1.42
| 4.0.23.1.42
|
| smarty | ≥ 4.0.0, < 4.0.2< 3.1.42
| 4.0.23.1.42
|
Description
Impact
Template authors could run arbitrary PHP code by crafting a malicious math string.
If a math string is passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string.
Patches
Please upgrade to 4.0.2 or 3.1.42 or higher.
References
See documentation on Math function.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
NVD description
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free