요약
- CVE-2023-34110은(는) flask-appbuilder, flask-appbuilder (flask-appbuilder project)에 영향을 주는 낮음 (CVSS 2.7) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.68%, 전체 취약점의 52.3%보다 높음.
- 조치: 4.3.2 이상으로 업데이트하세요.
Description
Impact
An authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password.
Patches
Fixed on 4.3.2
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free