요약
- CVE-2026-23535은(는) wlc, wlc (weblate)에 영향을 주는 높음 (CVSS 8.0) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.39%, 전체 취약점의 32.8%보다 높음.
- 조치: 1.17.2 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 1.17.2
| 1.17.2
|
| wlc | < 1.17.2
| 1.17.2
|
Description
Impact
Multi-translation download could write to an arbitrary location when instructed by a crafted server.
Patches
Workarounds
Do not use wlc download with untrusted servers.
References
This issue was reported to us by wh1zee via HackerOne.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free