요약
- CVE-2026-42150은(는) wlc, wlc (weblate)에 영향을 주는 보통 (CVSS 4.8) 취약점입니다.
- 향후 30일 내 악용 확률(EPSS): 0.17%, 전체 취약점의 6.8%보다 높음.
- 조치: 2.0.0 이상으로 업데이트하세요.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 2.0.0
| 2.0.0
|
| wlc | < 2.0.0
| 2.0.0
|
Description
Impact
The HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser.
Patches
Workarounds
The only vulnerable code path is HTML output which is opt-in.
References
Weblate thanks @fg0x0 for reporting this on GitHub.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to version 2.0.0, the HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser. This issue has been patched in version 2.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free