Em resumo
- CVE-2018-3778 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta aedes (aedes project), aedes.
- Chance de exploração nos próximos 30 dias (EPSS): 1.4%, maior que 72.9% das vulnerabilidades.
- Correção: atualize para 0.35.0, 0.35.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| aedes | < 0.35.0
| 0.35.0
|
| aedes npm | < 0.35.1
| 0.35.1
|
Description
Versions of aedes before 0.35.1 does not respect its own authorization rules when a client sets a Last Will.
Recommendation
Update to version 0.35.1 or later.
NVD description
Improper authorization in aedes version <0.35.0 will publish a LWT in a channel when a client is not authorized.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free