Em resumo
- CVE-2019-5415 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta serve (zeit), serve.
- Chance de exploração nos próximos 30 dias (EPSS): 1.6%, maior que 76.4% das vulnerabilidades.
- Correção: atualize para 7.0.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| serve | = 6.5.3
| No fix yet |
| serve npm | < 7.0.0
| 7.0.0
|
Description
Versions of serve prior to 7.0.1 are vulnerable to Path Traversal. Explicitly ignored folders can be accessed through if the path contains a /./, which allows attackers to access hidden folders and files.
Recommendation
Upgrade to version 7.0.1 or later.
NVD description
A bug in handling the ignore files and directories feature in serve 6.5.3 allows an attacker to read a file or list the directory that the victim has not allowed access to.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free