Em resumo
- CVE-2019-8324 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta rubygems-update, rubygems (rubygems).
- Chance de exploração nos próximos 30 dias (EPSS): 3.2%, maior que 88.2% das vulnerabilidades.
- Correção: atualize para 2.7.9, 3.0.2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| rubygems-update RubyGems | ≥ 2.6.0, < 2.7.9≥ 3.0.0, < 3.0.2
| 2.7.93.0.2
|
| rubygems | ≥ 2.6.0, ≤ 3.0.2
| No fix yet |
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.
NVD description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.
Mais vulnerabilidades de rubygems-update
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free