Em resumo
- CVE-2019-8325 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta rubygems-update, rubygems (rubygems).
- Chance de exploração nos próximos 30 dias (EPSS): 3.3%, maior que 88.4% das vulnerabilidades.
- Correção: atualize para 2.7.9, 3.0.2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| rubygems-update RubyGems | ≥ 2.6.0, < 2.7.9≥ 3.0.0, < 3.0.2
| 2.7.93.0.2
|
| rubygems | ≥ 2.6.0, ≤ 3.0.2
| No fix yet |
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)
NVD description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)
Mais vulnerabilidades de rubygems-update
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free