Em resumo
- CVE-2021-29621 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta flask-appbuilder, airflow (apache), flask-appbuilder (dpgaspar).
- Chance de exploração nos próximos 30 dias (EPSS): 3.4%, maior que 88.9% das vulnerabilidades.
- Correção: atualize para 3.3.0 ou posterior.
Description
Impact
User enumeration in database authentication in Flask-AppBuilder <= 3.2.3. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in.
Patches
Upgrade to 3.3.0
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is a development framework, built on top of Flask. User enumeration in database authentication in Flask-AppBuilder <= 3.2.3. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in. Upgrade to version 3.3.0 or higher to resolve.
Mais vulnerabilidades de flask-appbuilder
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free