Em resumo
- CVE-2021-32923 é uma vulnerabilidade ALTO (CVSS 7.4) que afeta github.com/hashicorp/vault, vault (hashicorp).
- Chance de exploração nos próximos 30 dias (EPSS): 1.4%, maior que 72.1% das vulnerabilidades.
- Correção: atualize para 1.5.9, 1.6.5, 1.7.2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 0.10.0, < 1.5.9≥ 1.6.0, < 1.6.5≥ 1.7.0, < 1.7.2
| 1.5.91.6.51.7.2
|
| vault | ≥ 0.10.0, < 1.5.9≥ 1.6.0, < 1.6.5≥ 1.7.0, < 1.7.2
| 1.5.91.6.51.7.2
|
Description
HashiCorp Vault and Vault Enterprise allowed the renewal of nearly-expired token leases and dynamic secret leases (specifically, those within 1 second of their maximum TTL), which caused them to be incorrectly treated as non-expiring during subsequent use. Fixed in 1.5.9, 1.6.5, and 1.7.2.
NVD description
HashiCorp Vault and Vault Enterprise allowed the renewal of nearly-expired token leases and dynamic secret leases (specifically, those within 1 second of their maximum TTL), which caused them to be incorrectly treated as non-expiring during subsequent use. Fixed in 1.5.9, 1.6.5, and 1.7.2.
Mais vulnerabilidades de github.com/hashicorp/vault
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free