Em resumo
- CVE-2021-41265 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta flask-appbuilder, flask-appbuilder (dpgaspar).
- Chance de exploração nos próximos 30 dias (EPSS): 1.3%, maior que 70.8% das vulnerabilidades.
- Correção: atualize para 3.3.4 ou posterior.
Description
Impact
Improper authentication on the REST API. Allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. Only affects non database authentication types, and new REST API endpoints.
Patches
Upgrade to Flask-AppBuilder 3.3.4
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.
Mais vulnerabilidades de flask-appbuilder
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free