Em resumo
- CVE-2022-21659 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta flask-appbuilder, flask-appbuilder (dpgaspar).
- Chance de exploração nos próximos 30 dias (EPSS): 0.95%, maior que 61.4% das vulnerabilidades.
- Correção: atualize para 3.4.2, 3.4.4 ou posterior.
Description
Impact
User enumeration in database authentication in Flask-AppBuilder < 3.4.4. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in.
Patches
Upgrade to 3.4.4
Workarounds
References
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is an application development framework, built on top of the Flask web framework. In affected versions there exists a user enumeration vulnerability. This vulnerability allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in. Users are advised to upgrade to version 3.4.4 as soon as possible. There are no known workarounds for this issue.
Mais vulnerabilidades de flask-appbuilder
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free