Em resumo
- CVE-2022-24685 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta github.com/hashicorp/nomad, nomad (hashicorp).
- Chance de exploração nos próximos 30 dias (EPSS): 1.5%, maior que 75.0% das vulnerabilidades.
- Correção: atualize para 1.0.17, 1.1.12, 1.2.6 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/nomad Go | ≥ 1.0.0, < 1.0.17≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6
| 1.0.171.1.121.2.6
|
| nomad | ≥ 1.0.0, ≤ 1.0.17≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6
| 1.1.121.2.6
|
Description
HashiCorp Nomad and Nomad Enterprise 1.x before 1.0.17, 1.1.x before 1.1.12, and 1.2.x before 1.2.6 is vulnerable to Allocation of Resources Without Limits or Throttling.
NVD description
HashiCorp Nomad and Nomad Enterprise 1.0.17, 1.1.11, and 1.2.5 allow invalid HCL for the jobs parse endpoint, which may cause excessive CPU usage. Fixed in 1.0.18, 1.1.12, and 1.2.6.
Mais vulnerabilidades de github.com/hashicorp/nomad
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free