Em resumo
- CVE-2022-31177 é uma vulnerabilidade BAIXO (CVSS 2.7) que afeta flask-appbuilder, flask-appbuilder (dpgaspar).
- Chance de exploração nos próximos 30 dias (EPSS): 0.77%, maior que 55.5% das vulnerabilidades.
- Correção: atualize para 4.1.3 ou posterior.
Description
Impact
An authenticated Admin user could craft HTTP requests to filter users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users.
Only when using AUTH_DB database authentication option.
Patches
Fixed on 4.1.3
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is an application development framework built on top of Flask python framework. In versions prior to 4.1.3 an authenticated Admin user could query other users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users. This issue has been fixed in version 4.1.3. Users are advised to upgrade. There are no known workarounds for this issue.
Mais vulnerabilidades de flask-appbuilder
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free