Em resumo
- CVE-2023-34110 é uma vulnerabilidade BAIXO (CVSS 2.7) que afeta flask-appbuilder, flask-appbuilder (flask-appbuilder project).
- Chance de exploração nos próximos 30 dias (EPSS): 0.68%, maior que 52.3% das vulnerabilidades.
- Correção: atualize para 4.3.2 ou posterior.
Description
Impact
An authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password.
Patches
Fixed on 4.3.2
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
Mais vulnerabilidades de flask-appbuilder
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free