Em resumo
- CVE-2023-41835 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta org.apache.struts:struts2-core, struts (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 7.3%, maior que 94.4% das vulnerabilidades.
- Correção: atualize para 6.1.2.2, 6.3.0.1, 2.5.32 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.struts:struts2-core Maven | ≥ 6.0.0, < 6.1.2.2≥ 6.2.0, < 6.3.0.1< 2.5.32
| 6.1.2.26.3.0.12.5.32
|
| struts | ≥ 2.0.0, < 2.5.32≥ 6.1.2.1, < 6.3.0.1
| 2.5.326.3.0.1
|
Description
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied.
Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fix this issue.
NVD description
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied.
Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fixe this issue.
Mais vulnerabilidades de org.apache.struts:struts2-core
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free