Em resumo
- CVE-2025-64775 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta org.apache.struts:struts2-core, struts (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 1.5%, maior que 74.7% das vulnerabilidades.
- Correção: atualize para 6.8.0, 7.1.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.struts:struts2-core Maven | ≥ 2.0.0, ≤ 2.3.37≥ 2.5.0, ≤ 2.5.33≥ 6.0.0, < 6.8.0≥ 7.0.0, < 7.1.1
| 6.8.07.1.1
|
| struts | ≥ 2.0.0, < 6.8.0≥ 7.0.0, < 7.1.1
| 6.8.07.1.1
|
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
NVD description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Mais vulnerabilidades de org.apache.struts:struts2-core
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free