Em resumo
- CVE-2023-46134 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta dtale, d-tale (man).
- Chance de exploração nos próximos 30 dias (EPSS): 0.86%, maior que 58.4% das vulnerabilidades.
- Correção: atualize para 3.7.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| dtale PyPI | < 3.7.0
| 3.7.0
|
| d-tale | < 3.7.0
| 3.7.0
|
Description
Impact
Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server.
Patches
Users should upgrade to version 3.7.0 where the "Custom Filter" input is turned off by default. You can find out more information on how to turn it back on here
Workarounds
The only workaround for versions earlier than 3.7.0 is to only host D-Tale to trusted users.
References
See "Custom Filter" documentation
NVD description
D-Tale is the combination of a Flask back-end and a React front-end to view & analyze Pandas data structures. Prior to version 3.7.0, users hosting D-Tale publicly can be vulnerable to remote code execution, allowing attackers to run malicious code on the server. This issue has been patched in version 3.7.0 by turning off "Custom Filter" input by default. The only workaround for versions earlier than 3.7.0 is to only host D-Tale to trusted users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free