Em resumo
- CVE-2023-5954 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta github.com/hashicorp/vault, vault (hashicorp).
- Chance de exploração nos próximos 30 dias (EPSS): 0.72%, maior que 53.9% das vulnerabilidades.
- Correção: atualize para 1.14.6, 1.15.2, 1.13.10 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 1.14.0, < 1.14.6≥ 1.15.0, < 1.15.2< 1.13.10
| 1.14.61.15.21.13.10
|
| vault | ≥ 1.13.7, < 1.13.10≥ 1.14.3, < 1.14.6≥ 1.15.0, < 1.15.2
| 1.13.101.14.61.15.2
|
Description
HashiCorp Vault and Vault Enterprise inbound client requests triggering a policy check can lead to an unbounded consumption of memory. A large number of these requests may lead to denial-of-service. Fixed in Vault 1.15.2, 1.14.6, and 1.13.10.
NVD description
HashiCorp Vault and Vault Enterprise inbound client requests triggering a policy check can lead to an unbounded consumption of memory. A large number of these requests may lead to denial-of-service. Fixed in Vault 1.15.2, 1.14.6, and 1.13.10.
Mais vulnerabilidades de github.com/hashicorp/vault
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free