Em resumo
- CVE-2024-21642 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta dtale, d-tale (man).
- Chance de exploração nos próximos 30 dias (EPSS): 0.71%, maior que 53.6% das vulnerabilidades.
- Correção: atualize para 3.9.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| dtale PyPI | < 3.9.0
| 3.9.0
|
| d-tale | < 3.9.0
| 3.9.0
|
Description
Impact
Users hosting D-Tale publicly can be vulnerable to server-side request forgery (SSRF) allowing attackers to access files on the server.
Patches
Users should upgrade to version 3.9.0 where the "Load From the Web" input is turned off by default. You can find out more information on how to turn it back on here
Workarounds
The only workaround for versions earlier than 3.9.0 is to only host D-Tale to trusted users.
References
See "Load Data & Sample Datasets" documentation
NVD description
D-Tale is a visualizer for Pandas data structures. Users hosting versions D-Tale prior to 3.9.0 publicly can be vulnerable to server-side request forgery (SSRF), allowing attackers to access files on the server. Users should upgrade to version 3.9.0, where the `Load From the Web` input is turned off by default. The only workaround for versions earlier than 3.9.0 is to only host D-Tale to trusted users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free