Em resumo
- CVE-2024-34693 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta apache-superset, superset (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 1.6%, maior que 75.6% das vulnerabilidades.
- Correção: atualize para 4.0.1, 3.1.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-superset PyPI | ≥ 4.0.0, < 4.0.1< 3.1.3
| 4.0.13.1.3
|
| superset | ≥ 4.0.0, < 4.0.1< 3.1.3
| 4.0.13.1.3
|
Description
Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table. This issue affects Apache Superset before version 3.1.3 and in version 4.0.0.
Users are recommended to upgrade to version 4.0.1 or 3.1.3, both of which fix the issue.
NVD description
Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0
Users are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.
Mais vulnerabilidades de apache-superset
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free