Em resumo
- CVE-2024-42468 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta org.openhab.ui.bundles:org.openhab.ui.cometvisu, openhab (openhab).
- Chance de exploração nos próximos 30 dias (EPSS): 0.81%, maior que 57.0% das vulnerabilidades.
- Correção: atualize para 4.2.1 ou posterior.
Description
openHAB's CometVisuServlet is susceptible to an unauthenticated path traversal vulnerability.
Local files on the server can be requested via HTTP GET on the CometVisuServlet.
This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query.
Impact
This issue may lead to Information Disclosure.
NVD description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. CometVisuServlet in versions prior to 4.2.1 is susceptible to an unauthenticated path traversal vulnerability. Local files on the server can be requested via HTTP GET on the CometVisuServlet. This issue may lead to information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
Mais vulnerabilidades de org.openhab.ui.bundles:org.openhab.ui.cometvisu
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free