Em resumo
- CVE-2025-24860 é uma vulnerabilidade MÉDIO (CVSS 5.4) que afeta org.apache.cassandra:cassandra-all, cassandra (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 1.1%, maior que 65.6% das vulnerabilidades.
- Correção: atualize para 4.0.16, 4.1.8, 5.0.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.cassandra:cassandra-all Maven | ≥ 4.0-alpha1, < 4.0.16≥ 4.1-alpha1, < 4.1.8≥ 5.0-alpha1, < 5.0.3
| 4.0.164.1.85.0.3
|
| cassandra | ≥ 4.0.0, < 4.0.16≥ 4.1.0, < 4.1.8≥ 5.0.0, < 5.0.3
| 4.0.164.1.85.0.3
|
Description
Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer.
Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions.
This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer.
Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
NVD description
Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer.
Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions.
This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer.
Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Mais vulnerabilidades de org.apache.cassandra:cassandra-all
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free