Em resumo
- CVE-2025-29847 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta org.apache.linkis:linkis, linkis (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 0.87%, maior que 59.0% das vulnerabilidades.
- Correção: atualize para 1.8.0 ou posterior.
Description
A vulnerability in Apache Linkis.
Problem Description
When using the JDBC engine and data source functionality, if the URL parameter configured on the frontend has undergone multiple rounds of URL encoding, it may bypass the system's checks. This bypass can trigger a vulnerability that allows unauthorized access to system files via JDBC parameters.
Scope of Impact
This issue affects Apache Linkis: from 1.3.0 through 1.7.0.
Severity level
moderate
Solution
Continuously check if the connection information contains the "%" character; if it does, perform URL decoding.
Users are recommended to upgrade to version 1.8.0, which fixes the issue.
More questions about this vulnerability can be discussed here: https://lists.apache.org/[email protected]:2025-9:cve
NVD description
A vulnerability in Apache Linkis.
Problem Description
When using the JDBC engine and da
When using the JDBC engine and data source functionality, if the URL parameter configured on the frontend has undergone multiple rounds of URL encoding, it may bypass the system's checks. This bypass can trigger a vulnerability that allows unauthorized access to system files via JDBC parameters.
Scope of Impact
This issue affects Apache Linkis: from 1.3.0 through 1.7.0.
Severity level
moderate
Solution
Continuously check if the connection information contains the "%" character; if it does, perform URL decoding.
Users are recommended to upgrade to version 1.8.0, which fixes the issue.
More questions about this vulnerability can be discussed here: https://lists.apache.org/[email protected]:2025-9:cve
Mais vulnerabilidades de org.apache.linkis:linkis
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free