Em resumo
- CVE-2026-34242 é uma vulnerabilidade ALTO (CVSS 7.7) que afeta weblate, weblate (weblate).
- Chance de exploração nos próximos 30 dias (EPSS): 0.46%, maior que 40.3% das vulnerabilidades.
- Correção: atualize para 5.17 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.17
| 5.17
|
| weblate | < 5.17
| 5.17
|
Description
Impact
The ZIP download feature didn't verify downloaded file and it could follow symlinks outside the repository.
Patches
References
Thanks to @DavidCarliez for reporting this vulnerability via GitHub.
NVD description
Weblate is a web based localization tool. In versions prior to 5.17, the ZIP download feature didn't verify downloaded files, potentially following symlinks outside the repository. This issue has been fixed in version 5.17.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free