Em resumo
- CVE-2026-41519 é uma vulnerabilidade MÉDIO (CVSS 5.4) que afeta weblate, weblate (weblate).
- Chance de exploração nos próximos 30 dias (EPSS): 0.27%, maior que 19.3% das vulnerabilidades.
- Correção: atualize para 5.17.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.17.1
| 5.17.1
|
| weblate | < 5.17.1
| 5.17.1
|
Description
Impact
When a user changes their password, browser sessions are correctly invalidated via cycle_session_keys(), but DRF API tokens (wlu_* prefix) stored in authtoken_token are not revoked.
Patches
Resources
Weblate thanks Sang Yu Jeon for reporting this via GitHub.
NVD description
Weblate is a web based localization tool. Prior to version 5.17.1, when a user changes their password, browser sessions are correctly invalidated via "cycle_session_keys()", but DRF API tokens ("wlu_*" prefix) stored in "authtoken_token" are not revoked. This issue has been patched in version 5.17.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free