Em resumo
- CVE-2026-42509 é uma vulnerabilidade MÉDIO (CVSS 6.1) que afeta org.apache.wicket:wicket-parent, wicket (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 0.36%, maior que 29.4% das vulnerabilidades.
- Correção: atualize para 10.9.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.wicket:wicket-parent Maven | ≥ 10.0.0-M1, < 10.9.0≥ 8.0.0-M1, ≤ 8.17.0≥ 9.0.0-M1, ≤ 9.22.0
| 10.9.0
|
| wicket | ≥ 10.0.0, < 10.9.0≥ 8.0.0, ≤ 8.17.0≥ 9.0.0, ≤ 9.22.0
| 10.9.0
|
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
NVD description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Mais vulnerabilidades de org.apache.wicket:wicket-parent
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free