| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| js-yaml | = 0.2.0= 0.2.1= 0.2.2= 0.3.0= 0.3.1= 0.3.2= 0.3.3= 0.3.4= 0.3.5= 0.3.6= 0.3.7= 1.0.0= 1.0.1= 1.0.2= 1.0.3= 2.0.0= 2.0.1= 2.0.2= 2.0.3≤ 2.0.4 | |
| js-yaml | < 2.0.5 | 2.0.5 |
Versions 2.0.4 and earlier of js-yaml are affected by a code execution vulnerability in the YAML deserializer.
const yaml = require('js-yaml');
const x = `test: !!js/function >
function f() {
console.log(1);
}();`
yaml.load(x);
Update js-yaml to version 2.0.5 or later, and ensure that all instances where the .load() method is called are updated to use .safeLoad() instead.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí