Tóm tắt nhanh
- CVE-2013-6393 là lỗ hổng mức TRUNG BÌNH (CVSS 6.8) ảnh hưởng libyaml (pyyaml), openstack (redhat), libyaml.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 7.4%, cao hơn 94.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.2.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| libyaml | = 0.0.1= 0.1.1= 0.1.2= 0.1.3≤ 0.1.4
| Chưa có bản vá |
| openstack | = 3.0= 4.0
| Chưa có bản vá |
| libyaml npm | < 0.2.3
| 0.2.3
|
Mô tả
Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags.
Recommendation
- Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.
Mô tả của NVD
The yaml_parser_scan_tag_uri function in scanner.c in LibYAML before 0.1.5 performs an incorrect cast, which allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted tags in a YAML document, which triggers a heap-based buffer overflow.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí