Tóm tắt nhanh
- CVE-2014-3741 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng node-printer (node-printer project), printer.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 3.8%, cao hơn 90.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.0.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| node-printer | ≤ 0.0.1
| Chưa có bản vá |
| printer npm | < 0.0.2
| 0.0.2
|
Mô tả
Versions 0.0.1 and earlier of printer are affected by a command injection vulnerability resulting from a failure to sanitize command arguments properly in the printDirect() function.
Recommendation
Update to version 0.0.2 or later.
Mô tả của NVD
The printDirect function in lib/printer.js in the node-printer module 0.0.1 and earlier for Node.js allows remote attackers to execute arbitrary commands via unspecified characters in the lpr command.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí