Tóm tắt nhanh
- CVE-2015-1370 là lỗ hổng mức TRUNG BÌNH (CVSS 4.3) ảnh hưởng marked (marked project), marked.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.0%, cao hơn 81.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.3.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| marked | ≤ 0.3.2
| Chưa có bản vá |
| marked npm | < 0.3.3
| 0.3.3
|
Mô tả
Versions 0.3.2 and earlier of marked are affected by a cross-site scripting vulnerability even when sanitize:true is set.
Proof of Concept ( IE10 Compatibility Mode Only )
[xss link](vbscript:alert(1))
will get a link
<a href="vbscript:alert(1)">xss link</a>
Recommendation
Update to version 0.3.3 or later.
Mô tả của NVD
Incomplete blacklist vulnerability in marked 0.3.2 and earlier for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks via a vbscript tag in a link.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí