Tóm tắt nhanh
- CVE-2015-5688 là lỗ hổng mức TRUNG BÌNH (CVSS 5.0) ảnh hưởng geddy (geddyjs), geddy.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 9.4%, cao hơn 95.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 13.0.8 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| geddy | = 13.0.7
| Chưa có bản vá |
| geddy npm | < 13.0.8
| 13.0.8
|
Mô tả
Versions 13.0.8 and earlier of geddy are vulnerable to a directory traversal attack via URI encoded attack vectors.
Proof of Concept
http://localhost:4000/..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2fetc/passwd
Recommendation
Update geddy to version >= 13.0.8
Mô tả của NVD
Directory traversal vulnerability in lib/app/index.js in Geddy before 13.0.8 for Node.js allows remote attackers to read arbitrary files via a ..%2f (dot dot encoded slash) in the PATH_INFO to the default URI.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí