Tóm tắt nhanh
- CVE-2015-8851 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng node-uuid (node-uuid project), node-uuid.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.3%, cao hơn 83.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.4.4 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| node-uuid | < 1.4.4
| 1.4.4
|
| node-uuid npm | < 1.4.4
| 1.4.4
|
Mô tả
Affected versions of node-uuid consistently fall back to using Math.random as an entropy source instead of crypto, which may result in guessable UUID's.
Recommendation
Update to version 1.4.4 or later.
Mô tả của NVD
node-uuid before 1.4.4 uses insufficiently random data to create a GUID, which could make it easier for attackers to have unspecified impact via brute force guessing.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí