Tóm tắt nhanh
- CVE-2015-8855 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng node.js (nodejs), semver.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 6.9%, cao hơn 94.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.3.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| node.js | ≤ 4.3.1
| Chưa có bản vá |
| semver npm | ≥ 1.0.4, < 4.3.2
| 4.3.2
|
Mô tả
Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed.
Recommendation
Update to version 4.3.2 or later
Mô tả của NVD
The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí