Tóm tắt nhanh
- CVE-2015-8857 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng uglifier, uglifyjs (uglifyjs project), uglify-js.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 3.6%, cao hơn 89.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.7.2, 2.4.24 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| uglifier RubyGems | < 2.7.2
| 2.7.2
|
| uglifyjs | < 2.4.24
| 2.4.24
|
| uglify-js npm | < 2.4.24
| 2.4.24
|
Mô tả
Versions of uglify-js prior to 2.4.24 are affected by a vulnerability which may cause crafted JavaScript to have altered functionality after minification.
Recommendation
Upgrade UglifyJS to version >= 2.4.24.
Mô tả của NVD
The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí