Tóm tắt nhanh
- CVE-2016-10537 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng backbone (backbone project), backbone.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.68%, cao hơn 52.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.5.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| backbone | ≤ 0.3.3
| Chưa có bản vá |
| backbone npm | ≥ 0.3.3, < 0.5.0
| 0.5.0
|
Mô tả
Affected versions of backbone are vulnerable to cross-site scripting when users are allowed to supply input to the Model#Escape function, and the output is then written to the DOM.
The vulnerability occurs as a result of the regular expression used to encode metacharacters failing to take HTML Entities such as < into account.
Recommendation
Update to version 0.5.0 or later.
Mô tả của NVD
backbone is a module that adds in structure to a JavaScript heavy application through key-value pairs and custom events connecting to your RESTful API through JSON There exists a potential Cross Site Scripting vulnerability in the `Model#Escape` function of backbone 0.3.3 and earlier, if a user is able to supply input. This is due to the regex that's replacing things to miss the conversion of things such as `<` to `<`.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí