Tóm tắt nhanh
- CVE-2016-10539 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng negotiator (negotiator project), negotiator.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.4%, cao hơn 72.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.6.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| negotiator | ≤ 0.6.0
| Chưa có bản vá |
| negotiator npm | < 0.6.1
| 0.6.1
|
Mô tả
Affected versions of negotiator are vulnerable to regular expression denial of service attacks, which trigger upon parsing a specially crafted Accept-Language header value.
Recommendation
Update to version 0.6.1 or later.
Mô tả của NVD
negotiator is an HTTP content negotiator for Node.js and is used by many modules and frameworks including Express and Koa. The header for "Accept-Language", when parsed by negotiator 0.6.0 and earlier is vulnerable to Regular Expression Denial of Service via a specially crafted string.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí