Tóm tắt nhanh
- CVE-2016-10546 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng pouchdb (pouchdb), pouchdb.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.6%, cao hơn 85.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.0.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| pouchdb | ≤ 6.0.4
| Chưa có bản vá |
| pouchdb npm | < 6.0.5
| 6.0.5
|
Mô tả
Affected versions of pouchdb do not properly sandbox the code execution engine which executes the map/reduce functions for temporary views and design documents. Under certain circumstances, an attacker could uses this to run arbitrary code on the server.
Recommendation
Update to version 6.0.5 or later.
Mô tả của NVD
An arbitrary code injection vector was found in PouchDB 6.0.4 and lesser via the map/reduce functions used in PouchDB temporary views and design documents. The code execution engine for this branch is not properly sandboxed and may be used to run arbitrary JavaScript as well as system commands.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí