Tóm tắt nhanh
- CVE-2016-10550 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng sequelize (sequelizejs), sequelize.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.9%, cao hơn 79.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.17.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| sequelize | ≤ 3.16.0
| Chưa có bản vá |
| sequelize npm | < 3.17.0
| 3.17.0
|
Mô tả
Affected versions of sequelize are vulnerable to SQL Injection in locations where user input is passed into the limit or order parameters of sequelize query calls, such as findOne or findAll.
Recommendation
Update to version 3.17.0 or later.
Mô tả của NVD
sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS If user input goes into the `limit` or `order` parameters, a malicious user can put in their own SQL statements. This affects sequelize 3.16.0 and earlier.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí